Sunday, July 13, 2014

How to set Kernel Parameters in AIX?

One of my New IBM 7.1  Server, I was hitting this issue while working on Putty,

bash: fork: retry: There are no child processes.
bash: fork: retry: There are no child processes.
bash: fork: retry: There are no child processes.
bash: fork: retry: There are no child processes.

bash: fork: Resource temporarily unavailable

This was due to less maxuproc processes which later changed to higher value i.e.  8192 per user, and issue resolved.

Unlike many other UNIX operating systems, AIX does not provide the ability to directly configure most kernel parameters. Instead, the AIX kernel dynamically allocates and reallocates resources as they are needed (up to a predefined limit).
To see all the current values assigned to the kernel parameters, enter:
# lsattr -E -l sys0
or
# smit chgsys ( Change / Show Characteristics of Operating System)
To see the current values assigned to for example maxuproc, enter:
# lsattr -E -l sys0 -a maxuproc
maxuproc 128 Maximum number of PROCESSES allowed per user True

To change the value assigned to maxuproc parameter, enter:
# chdev -l sys0 -a maxuproc=1000
sys0 changed 

or
# smit chgsys
The following is another command that writes system wide configuration variable values to the standard output:
# getconf -a
AIO_LISTIO_MAX: 4096
AIO_MAX: 4096
AIO_PRIO_DELTA_MAX: 0
ARG_MAX: 24576
ATEXIT_MAX: 2048
BC_BASE_MAX: 99
BC_DIM_MAX: 2048
BC_SCALE_MAX: 99
BC_STRING_MAX: 2048
BOOT_DEVICE: hdisk0
CHARCLASS_NAME_MAX: 14
CHAR_BIT: 8
CHAR_MAX: 255
CHAR_MIN: 0
CHILD_MAX: 128
CLK_TCK: 100
COLL_WEIGHTS_MAX: 4
CS_PATH: /usr/bin:/usr/vac/bin
DELAYTIMER_MAX: 32
EXPR_NEST_MAX: 32
FILESIZEBITS: undefined
HARDWARE_BITMODE: 64
HOST_NAME_MAX: 256
To see the current value assigned to for example CS_PATH, enter:
# getconf CS_PATH
/usr/bin:/usr/vac/bin

How to find out the IBM XL C/C++ Compiler Version for EBS on AIX Server ?

# lslpp -l | grep vacpp

root@ebs01:/#lslpp -l | grep vacpp
  vacpp.Bnd                 12.1.0.0  COMMITTED  IBM XL C/C++ Media Defined
  vacpp.cmp.aix50.lib
  vacpp.cmp.aix50.tools
  vacpp.cmp.aix52.lib
  vacpp.cmp.aix52.tools
  vacpp.cmp.aix53.lib       12.1.0.0  COMMITTED  IBM XL C/C++ Libraries for AIX
  vacpp.cmp.aix53.tools     12.1.0.0  COMMITTED  IBM XL C/C++ Tools for AIX 5.3
  vacpp.cmp.core            12.1.0.0  COMMITTED  IBM XL C/C++ Compiler
  vacpp.cmp.include         12.1.0.0  COMMITTED  IBM XL C/C++ Compiler Include
  vacpp.cmp.lib             12.1.0.0  COMMITTED  IBM XL C/C++ Libraries
  vacpp.cmp.rte             12.1.0.0  COMMITTED  IBM XL C/C++ Compiler
  vacpp.cmp.tools           12.1.0.0  COMMITTED  IBM XL C/C++ Tools
  vacpp.lic                 12.1.0.0  COMMITTED  IBM XL C/C++ Licence Files
  vacpp.licAgreement        12.1.0.0  COMMITTED  IBM XL C++ Electronic License
  vacpp.man.en_US           12.1.0.0  COMMITTED  IBM XL C/C++ Compiler Man
  vacpp.memdbg.aix50.lib
  vacpp.memdbg.aix50.rte
  vacpp.memdbg.aix52.lib
  vacpp.memdbg.aix52.rte
  vacpp.memdbg.aix53.lib    12.1.0.0  COMMITTED  IBM XL C/C++ User Heap/Memory
  vacpp.memdbg.aix53.rte    12.1.0.0  COMMITTED  IBM XL C/C++ User Heap/Memory
  vacpp.memdbg.lib          12.1.0.0  COMMITTED  IBM XL C/C++ User Heap and
  vacpp.memdbg.rte          12.1.0.0  COMMITTED  IBM XL C/C++ User Heap and
  vacpp.msg.en_US.cmp.core  12.1.0.0  COMMITTED  IBM XL C/C++ Compiler
  vacpp.msg.en_US.cmp.tools
  vacpp.ndi                 12.1.0.0  COMMITTED  IBM XL C/C++ Non-Default
  vacpp.pdf.en_US           12.1.0.0  COMMITTED  IBM XL C/C++ Documentation
  vacpp.samples.ansicl      12.1.0.0  COMMITTED  IBM XL C/C++ Compiler ANSI

  vacpp.cmp.core            12.1.0.0  COMMITTED  IBM XL C/C++ Compiler

To get IBM AIX Server Details,

# prtconf | more

To Unlock user in AIX,

# chuser unsuccessful_login_count=0 <username>

# chuser account_locked=false <username>

To start X11 in AIX

Turn on X11Forwarding in /etc/ssh/sshd_config and restart sshd.

Find X11Forwarding and make sure its uncommented and set to yes.

X11Forwarding yes

#stopsrc -s sshd; startsrc -s sshd


vi /etc/ssh/sshd_config

Reference: 1294357.1 - New Oracle E-Business Suite R12 Operating System and Tools Requirements on IBM AIX on Power Systems

Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for IBM AIX on Power Systems (64-bit) (Doc ID 761569.1)

1 comment:

  1. Thanks for providing this informative information. it is very useful you may also refer- http://www.s4techno.com/blog/2016/07/11/to-get-set-acl-in-aix/

    ReplyDelete